Is GeoServer ready for Java 1.5?

We’ve recently been kicking around the notion of requiring Java 1.5 to run GeoServer. There are a few nice features, such as generics and annotations, that are useful when you’re aiming to be a framework instead of just an application. And some potential libraries, like user interface ones, are starting to require Java 1.5. Other things pointing towards why it might be ok include the fact that Java will be open sourced soon, so it will be even easier for non core platforms to run GeoServer. But we figured the best way to figure out is to ask you, the users. If you have or are a sys admin who just isn’t ready to upgrade to Java 1.5, let us know. We realize that it’s a server application and admins like things stable. But with Java 1.6 out, and 1.5 very, very stable, we’re thinking it might be time. So please vote in the poll below, and place comments on this post if the options don’t do it for you. We will strongly take this feedback in to account for our decision.


Create polls and vote for free. dPolls.com

6 Comments

  1. Posted 2007/04/25 at 8:17 pm | Permalink

    Umm… The poll thingy was broken when I tried to vote just now.

    I support a move to 1.5.

  2. Justin Deoliveira
    Posted 2007/04/25 at 8:52 pm | Permalink

    An article that may be of interest.

    http://www.javalobby.org/java/forums/t93054.html

  3. Posted 2007/04/26 at 3:38 am | Permalink

    +1 for Java 1.5

  4. Jody Garnett
    Posted 2007/04/26 at 11:27 am | Permalink

    This is a tough call … we have waited as long as we said we would, however the Java EE world does not move quickly. I don’t think Java 5 will be an option everywhere until WebSphere and OC4J have an implementation.

    That said we have limited resources and it is expensive to maintain a Java 1.4 development stream; we have already forked entire codebases (JUnit vs JScience) and are missing out on some of the Goodness that would be helpful in defining a configuration system (Hibernate 3), or contribute to a lightweight dispatch system (annotations). Spring has bought us a lot of time on both these fronts.

    This is kind of the reason to have a PSC – to make tough decisions like this. Given the development focus of the current PSC I suspect that Java 5 will be adopted (in order to minimize development costs). I would recommend calling a Java 5 version of GeoServer 2.0 just to make the distinction clear.

  5. Bryan Hall
    Posted 2007/04/27 at 2:18 am | Permalink

    Absolutely. Most of our POJO web service code already requires 1.5, so we are already running geoserver on a 1.5 engine due to this.

  6. Posted 2007/04/27 at 5:23 pm | Permalink

    I do agree that we should probably call it GeoServer 2.0 when we require Java 1.5. The big thing for me for GeoServer 2.0 is changes in configuration, not being backwards compatible – that definitely means we need a 2.0. But I think that will likely happen soon, so we if no one is against it we may as well require Java 1.5 for that.

Download GeoServer