GeoServer 2.12.5 released

We are happy to announce the release of GeoServer 2.12.5. Downloads are available (zipwar, and exe) along with docs and extensions.

This is the last maintenance release for the 2.12.x series, so we recommend users to plan an upgrade to 2.13.x or to the upcoming 2.14.x series. This release is made in conjunction with GeoTools 18.5.

Highlights of this release are featured below, for more information please see the release notes (2.12.52.12.42.12.3,2.12.22.12.12.12.0 | 2.12-RC1 | 2.12-beta).

Improvements

  • ImageMosaic should work when the images have no CRS information
  • Upgrade Apache POI dependencies
  • Upgrade jasypt dependency
  • Upgrade json-lib dependency to 2.4
  • Upgrade bouncycastle provider to 1.60

Bug Fixes

  •  NullPointerException during WMS request of layer group when caching is enabled
  • GeorectifyCoverage fails to handle paths with spaces
  •  CSS translator does not support mark offset/anchors based on expressions (but SLD does)
  • GeoServerSecuredPage might not redirect to login page in some obscure cases after Wicket upgrade

Security updates

Please update your production instances of GeoServer to receive the latest security updates and fixes.

This release addresses several security vulnerabilities:

  • Prevent arbitrary code execution via Freemarker Template injection
  • XXE vulnerability in GeoTools XML Parser
  • XXE vulnerability in WPS Request builder
  • Various library upgrades (see above) from versions with known CVEs

Thanks to Steve Ikeoka, Kevin Smith, Brad Hards and Nuno Oliveira for providing fixes to these issues.

These fixes are also included in the 2.13.2 release.

If you encounter a security vulnerability in GeoServer, or any other open source software, please take care to report the issue in a responsible fashion.

About GeoServer 2.12 Series

Additional information on the 2.12 series:

Download GeoServer